PDA

View Full Version : Config. of wireless network fails on reboot


Tore_65
16th September 2007, 11:47 PM
(I do only have one week of Linux/Fedora experience so please take it slow.....)

Background:
I am running Fedora 7.
I have a D-link DWL-G520 PCI Adapter.
I have downloaded the madwifi driver (madwifi-0.9.3.2) from
"http://sourceforge.net/project/showfiles.php?group_id=82936&package_id=85233" and installed it according to the instructions in the HowTo article at "http://madwifi.org/wiki/UserDocs/FirstTimeHowTo".

Everything works fine at this point and I am connected to the network as expected.

My problem:
is that the network adapter configuration fails on next reboot. The configuration settings does not seams to be saved......?

When I run the following commands (after reboot)
[root@localhost ~]# iwconfig ath0 essid "Solstuen"
[root@localhost ~]# iwconfig ath0 key xxxxx (My key)
[root@localhost ~]# iwpriv ath0 authmode 1
[root@localhost ~]# dhclient ath0

the adapter connects properly and I am networked again.

Is there a file I have to edit to make the configuration "stick"? (startup script?)

Any help is appreciated
Best regards Tore

For information, the output from running iwconfig and ifconfig (after running the commands above)
-----------------------------------
[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"Solstuen" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: 00:0F:3D:09:6F:E1
Bit Rate:54 Mb/s Tx-Power:16 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:2142-01BE-AF Security mode:restricted
Power Management:off
Link Quality=26/70 Signal level=-69 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

--------------------
[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:0F:3D:AA:8B:1B
inet addr:192.168.0.110 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20f:3dff:feaa:8b1b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:83527 errors:0 dropped:0 overruns:0 frame:0
TX packets:44286 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:117621016 (112.1 MiB) TX bytes:3116475 (2.9 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6593 errors:0 dropped:0 overruns:0 frame:0
TX packets:6593 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:35784936 (34.1 MiB) TX bytes:35784936 (34.1 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-0F-3D-AA-8B-1B-A8-A9-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:108977 errors:0 dropped:0 overruns:0 frame:6265
TX packets:60280 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:122691158 (117.0 MiB) TX bytes:5182021 (4.9 MiB)
Interrupt:21

ppesci
17th September 2007, 12:54 AM
You can save settings in the menu K menu > Administration > Network configuration. If ath0 doesn't appear, create a new interface and configure it.

HTH

Hovelhof Travel Photos - Oyama Photos on Instagram - Kobe Travel Photos