PDA

View Full Version : Yet another Netgear WG511t question - F7


rugbert
30th August 2007, 07:40 PM
I bought the card since it was supported by madwifi, but i cant get it to work. I installed madwifi from ATrpms, but F7 wont detect the card.

I read a post (I cant find it now tho) about how after installing the madwifi drivers, all you need to do is (after starting Network Manager and NMDispatch) pt the card in. Well nothing happens.

Can someone help me out? Im going to uninstall madwifi so I can do this from the start.

Brian1
30th August 2007, 10:43 PM
Post output from the following commands.
/sbin/lspci -v
/sbin/ifconfig -a
rpm -qa | grep madwifi
uname -r

Now have you installed both the madwifi rpm and kmod madwifi rpm?
Does the kmod rpm match kernel version you are running?

Here are basic config files to get non secure atheros based card up.
dhcp connection file:///etc/sysconfig/network-scripts/ifcfg-ath0
change default1 on the ESSID line to match yours if other wireless routers exist in range of your card.

# NAME='Linksys WPC55AG' Home Static Setup
# STARTMODE='auto'
ONBOOT=yes
DEVICE=ath0
ESSID=default1
MODE=Managed
BOOTPROTO=dhcp
WIRELESS=yes
RATE=auto

Also if you have a wired network card then edit the similiar named file in /etc/sysconfig/network-scripts/ifcfg-**** and change the onboot=yes to onboot=no.

Once the file is created and saved then do the following.
/sbin/modprobe ath_pci ( load the atheros module. if it errors then the module is not installed )
/sbin/ifdown eth0 ( or any other running network interfaces )
/sbin/ifup ath0 ( this will bring up the interface using a dhcp setup to the router. )
Ping your routers ip. ping -c5 xxx.xxx.xxx.xxx

Brian

Kanye Instagram Photos - Rockland Travel Photos - Torremaggiore Travel Photos on Instagram