PDA

View Full Version : Defining a certain kernel to always load


LinuxNub
29th April 2004, 08:17 PM
Im not sure why but for some reason ntplsmp or fedora reg kernel seems to have a problem booting up but when i use Fedora-up (non-smp) it boots up fine no problems.

Got any suggestions?

SuperNu
30th April 2004, 04:55 AM
If your system is a uniprocessor system (only one cpu), then using a smp enabled kernel could cause trouble, except if you are using a hyper threading pentium 4. If you don't have any problems with the uniprocessor kernel, then always boot that kernel. If you could give out your hardware specs, it might help out also.

--SN

LinuxNub
30th April 2004, 05:11 PM
3.06 ghz with HT p4
512 ram
80 gig hd SATA
IDE 24x cdrom

SuperNu
30th April 2004, 08:15 PM
Since you have a hyperthreaded Pentium 4, you should use a smp-enabled kernel. Which kernel is giving you problems on boot up? Is it a Fedora supplied kernel or one you compiled on your own? What error messages are you seeing, if any?

--SN

LinuxNub
30th April 2004, 08:18 PM
When the bootup is going and deamon on the system seems to freeze up the whole startup on that kernel. (sendmail , httpd , crond , ect.. causes the freeze) and it just sits there. Very very annoying =/

Its the fedora supplied kernel.

LinuxNub
30th April 2004, 09:14 PM
i turned off xinet and smp logged fine but for later references if i want to run daemons / http / ftp ect... wont not having xinet make it quite difficult?

theres an update to a 2.8 smp kernel for i686 but would that help. For certain reasons im sure it has kernel updates in up2date ignored.

Diwek Photos - Minamata - Cutral-Co Travel Photos on Instagram