PDA

View Full Version : Xlib extension GLX error


saa_1973
24th June 2007, 10:33 AM
I get the following error:

Xlib extension GLX missing on display localhost:0 in both Fedora Core 6 and Fedora 7 installations.

Help in this regard will be highly appreciated.

saa_1973.

cicatrix1
24th June 2007, 11:45 AM
I would start by searching these forums or google for a combination of the words xorg, glx, and the name of your video card manufacturer (I.E. ati, nvidia, intel). You should find plenty of things to get you started.

If you do not, please post back here with the result of the command lspci, and your /etc/X11/xorg.conf file. Other useful pieces of information for tracking down video problems are what specific graphics card/chipset you've got, and any warnings or errors that you might find in your xorg logs: grep -E 'WW|EE' /var/log/Xorg.0.log

saa_1973
24th June 2007, 12:49 PM
thanks for your post. I would follow the same and revert back.

saa_1973
24th June 2007, 01:03 PM
#grep -E 'WW|EE' /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) No monitor specified for screen "Screen0".
(WW) The core pointer device wasn't specified explicitly in the layout.
(WW) No FontPath specified. Using compiled-in default.
(II) Loading extension MIT-SCREEN-SAVER
(WW) I810(0): Bad V_BIOS checksum
(WW) I810(0): Bad V_BIOS checksum
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): PGTBL_ER is 0x00000029
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Extended BIOS function 0x5f28 not supported.
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32
(WW) <default pointer>: No Device specified, looking for one...
(WW) I810(0): Successfully set original devices
(WW) I810(0): Setting the original video mode instead of restoring
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Successfully set original devices (2)
(WW) I810(0): PGTBL_ER is 0x00000029
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Extended BIOS function 0x5f28 not supported.
(WW) I810(0): Successfully set original devices
(WW) I810(0): Setting the original video mode instead of restoring
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Successfully set original devices (2)
(WW) I810(0): PGTBL_ER is 0x00000029
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Extended BIOS function 0x5f28 not supported.
(WW) I810(0): Successfully set original devices
(WW) I810(0): Setting the original video mode instead of restoring
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Successfully set original devices (2)
(WW) I810(0): PGTBL_ER is 0x00000029
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Extended BIOS function 0x5f28 not supported.

# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 Modem: ALi Corporation SmartLink SmartPCI563 56K Modem
01:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)



# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

I hope this information with help in solving my problem.

Thanks.

saa_1973.

leigh123linux
24th June 2007, 01:12 PM
try this xorg.conf

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection


Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "auto"
#HorizSync 30.0 - 70.0
#VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 845"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

saa_1973
24th June 2007, 09:44 PM
The xorg.cong file did not resolve the issue.

I however understood that the application fluent required the driver x11 to be specified and the issue thus got resolved.

But I observed the problem lies with fc6 and f7 and never had the problem in fc5.

Ketanggungan Travel Photos - Braunschweig Instagram Photos - Tirana Photos