PDA

View Full Version : Nvidia kernel disabled after FC6 updates


kang0o
28th January 2007, 10:53 AM
I hadn't booted Fedora for about a week, when I did I got the normal stack of updates to download. I let it get on with it untill I saw the prompt to reboot, which I did. On reboot I got the message Xserver had failed to start and just got the shell no GUI. I managed to reinstall the nvidia drivers and while I was in FC6 it appeared to be ok except the GLX desktop effects no longer worked. Trouble is that every time I reboot I get the message 'Nvidia kernel driver disabled' (or words to that effect). and after I login all i get is the most basic of drivers 800x600 max res 3D apps don't work ect.
I really am just scratching my head now without a clue of how to fix this. As before the update the nvidia glx drivers worked perfectly, desktop effects and all 3D apps worked brilliantly.
Anyone got an ideas? any feedback greatfully recieved, cheers.

kang0o
28th January 2007, 11:48 AM
I read the text again and it appears to not be able to find nvidia-kernel-module on boot and as a result doesn't load the nvidia-glx driver.

How do I fix this?

leigh123linux
28th January 2007, 11:50 AM
reinstall it

kang0o
28th January 2007, 12:29 PM
It just says 'nothing to do'

leigh123linux
28th January 2007, 12:37 PM
try

yum remove kmod-nv* xorg-x11-drv-nv*

the * is part of the command

reboot

yum install kmod-nvidia xorg-x11-drv-nvidia
yum update kmod-nvidia xorg-x11-drv-nvidia
service nvidia-glx restart

kang0o
28th January 2007, 01:19 PM
I tried the first command but got this output from the terminal? any ideas?

[root@192 kang0o]# yum remove kmod-nv* xorg-x11-drv-nv*
Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[root@192 kang0o]#

I also tried restarting the service, but got the message 'bash: service: command not found' again any ideas?

leigh123linux
28th January 2007, 01:37 PM
you have another instance of yum running , check the top right hand corner for a box that looks like a package and right click and select quit them try again.

leigh123linux
28th January 2007, 01:38 PM
I tried the first command but got this output from the terminal? any ideas?

[root@192 kang0o]# yum remove kmod-nv* xorg-x11-drv-nv*
Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[root@192 kang0o]#

I also tried restarting the service, but got the message 'bash: service: command not found' again any ideas?

all commands must be done as su - and not su

kang0o
28th January 2007, 01:53 PM
I'm sorry but I didn't understand that last bit the su- stuff.

One strange thing I have discovered, if I edit the xorg.conf and change the driver from "nv" to "nvidia". I then get the nvidia splash screen and am able to see the config tabs inside the nvidia display settings GUI. 3D apps load but don't work properly. Desktop effect don't work at all, but the driver is deffinately working to a point. However evry time I reboot it goes back to not working at all and the xorg.conf has been rewritten back to the default "nv".
Really am struggling just seems to have a mind of it's own at the mo, anymore help would be really appreciated :)

kang0o
28th January 2007, 02:33 PM
Ok I understand now, I logged in as root followed your instructions and the kmod was uninstalled and reinstalled updated and the nvidia-glx service was restarted. But on rebooting was still not right, I installed the nvidia drivers again and while it was on 3D apps worked but desktop effects didn't.
Well I say 3D apps worked but only if after 1min all the controls reversed :( counts as working. And again on reboot the driver doesn't load :( WTF is going on?

leigh123linux
28th January 2007, 02:38 PM
I cant explain why xorg.conf is getting rewritten on reboot , but I have seen other posts this week complaining about this issue.

kang0o
28th January 2007, 03:27 PM
I might have to wait for an update then. Poxy thing, it was working perfectly upto yesterday.

leigh123linux
28th January 2007, 03:28 PM
I might have to wait for an update then. Poxy thing, it was working perfectly upto yesterday.

what card are you using

kang0o
28th January 2007, 03:58 PM
It is an Mx460

leigh123linux
28th January 2007, 04:02 PM
Your card is not supported by this driver

try

yum remove kmod-nv* xorg-x11-drv-nv*

the * is part of the command

reboot

yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx
yum update kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx
service nvidia-glx restart

kang0o
28th January 2007, 05:04 PM
ok tried that. On restarting nvidia-glx I got this output

Disabling nvidia-glx driver [OK]
Checking for nvidia module [FAILED]
nvidia.ko module for 2.6.19-1.2895.fc6xen kernel not found
Disabling nvidia-glx driver [OK]

kang0o
28th January 2007, 05:07 PM
I am currently downloading some updates after running

yum update nvidia kernel module

leigh123linux
28th January 2007, 05:15 PM
Why are you using a xen kernel do you need it, if not remove it and use the standard kernel as the xen kernel can cause problems like this.

kang0o
28th January 2007, 05:17 PM
I didn't think I was, I will have a look at the grub.conf after this dl finishes

leigh123linux
28th January 2007, 05:20 PM
remove the xen kernel and headers if installed with add and remove software.

kang0o
28th January 2007, 05:44 PM
Ok I think I must of clicked on the xen kernel by accident, because this time I selected the standard kernel, booted and the nvidia drivers and kernel loaded using the 96xx drivers.
As my user not root desktop effects are working again, but the only resolution I can use is 800x600. If I try and use any bigger res I get a small desktop in the top left corner and the rest of the screen is full of corruption. I can move the pointer but cannot select anything and have to wait till the screen reverts back automatically after 12secs or whatever.
Deffinately an improvement from earlier but still not 100%. Haven't tried 3D yet either, will do so now.
Thanks for your help so far :)

leigh123linux
28th January 2007, 05:50 PM
try

su -
system-config-display

and select a suitable monitor

kang0o
28th January 2007, 06:12 PM
I can change res as root but not as my user, I do the same procedure but when I log out and back in to x nothing has changed still at 800x600. Where as when logged in as root and you change the res it does it there and then, and it doesn't ask you to log out of x either.
3D performance is very poor, I know the card is old but untill the up date the few games I have installed on here used to fly.
One strange thing I noticed after running system-config-display was that the video card was labeled 'unknown' where as before it knew it was an nvidia mx460.

leigh123linux
28th January 2007, 06:18 PM
I can change res as root but not as my user, I do the same procedure but when I log out and back in to x nothing has changed still at 800x600. Where as when logged in as root and you change the res it does it there and then, and it doesn't ask you to log out of x either.
3D performance is very poor, I know the card is old but untill the up date the few games I have installed on here used to fly.
One strange thing I noticed after running system-config-display was that the video card was labeled 'unknown' where as before it knew it was an nvidia mx460.

post your xorg.conf

kang0o
28th January 2007, 06:24 PM
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "Philips 150C5 (15inch)"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 63.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

kang0o
28th January 2007, 06:38 PM
http://www.kang0o.net/images/Screenshot_sm.png (http://www.kang0o.net/images/Screenshot.png)

leigh123linux
28th January 2007, 06:40 PM
try this

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Module"
Load "type1"
Load "freetype"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Philips 150C5 (15inch)"
### Comment all HorizSync and VertSync values to use DDC:
#HorizSync 30.0 - 63.0
#VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

kang0o
28th January 2007, 07:27 PM
I did that, but when I tried to log into my user xserver failed to start.

leigh123linux
28th January 2007, 07:53 PM
ok try this


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Module"
Load "type1"
Load "freetype"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Philips 150C5 (15inch)"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 63.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

kang0o
28th January 2007, 09:08 PM
No mate still get the corruption and the res doesn't change.

leigh123linux
28th January 2007, 09:15 PM
No mate still get the corruption and the res doesn't change.

Ok this is a guess and will disable the rhgb

su -
gedit /boot/grub/grub.conf

and remove the rhgb from all the enties

title GNU/Linux Fedora Core 1 (2.4.22-1.2174.nptl)
root (hd0,2)
kernel /vmlinuz-2.4.22-1.2174.nptl ro root=LABEL=/ hdc=ide-scsi apm=off acpi=on rhgb
initrd /initrd-2.4.22-1.2174.nptl.img

kang0o
29th January 2007, 09:13 AM
I edited the grub.conf and removed rhgb. I also removed 'quiet' as that was behind rhgb (see before and after below). I rebooted and it did boot differently, but once in my user account nothing had changed. If I use system-config-display I change the res, it asks me to log out of xserver for the settings to take effect. I do the above and nothing has changed. Or if I use the nvidia display settings gui I get the corruption. This really is doing my swede in.
Would like to thank you for your help though, really appreciate it.

before/after grub.conf

title Fedora Core (2.6.19-1.2895.fc6)
root (hd0,0)
kernel /vmlinuz-2.6.19-1.2895.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.19-1.2895.fc6.img


title Fedora Core (2.6.19-1.2895.fc6)
root (hd0,0)
kernel /vmlinuz-2.6.19-1.2895.fc6 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.19-1.2895.fc6.img

Calgary Travel Photos on Instagram - Netherlands Photos - Yaounde Instagram Photos -