PDA

View Full Version : Ctrl+Alt+TAB in fullscreen games


The_Rooster
16th December 2006, 07:21 PM
So, when gaming for example ET and TC:E you sometimes want to get your desktop up for writing a IM-message or something like that.

The only current way i've fond to do this is:
In ET and TC:E: first press Ctrl+Alt+enter --> switch workspace --> wait a few sec -->switch back to the first workspace --> Ctrl+Alt+TAB

First now you can answer your message, this is enormously annoying and time-consuming to do.
Would be much better to be able to do the windows-way, just press Ctrl+Alt+TAB and have your IM-window up.

So, is there ANY way to make this simpler? I just cant stand the current way.

bigjoe4265
16th December 2006, 08:38 PM
Rooster,

I've been wondering this myself, I run ET in a window at 1024x768, and would like this. I haven't found the answer either. If you do please shoot me an private IM.

Thanks,

Bigjoe

bigjoe4265
16th December 2006, 08:51 PM
Rooster,

I found this in a goolge search. Don't know if it works, haven't tried it yet, but it's worth a shot.

add the following to the ServerFlags section of your xorg.conf or XF86Config file.
If you dont have a ServerFlags section in your conf file it should look like this


Code:

Section "ServerFlags"
Option "AllowDeactivateGrabs" "true"
EndSection

Once X has been restarted you can use Ctrl-Alt-numpad_divide key to ungrab the mouse

The_Rooster
16th December 2006, 09:10 PM
Rooster,

I found this in a goolge search. Don't know if it works, haven't tried it yet, but it's worth a shot.

add the following to the ServerFlags section of your xorg.conf or XF86Config file.
If you dont have a ServerFlags section in your conf file it should look like this


Code:

Section "ServerFlags"
Option "AllowDeactivateGrabs" "true"
EndSection

Once X has been restarted you can use Ctrl-Alt-numpad_divide key to ungrab the mouse


Nope, didn't seem to be working
With Ctrl-Alt-numpad_divide key I am able to tab trough the desktop-windows, but when i switch back to the game neither the mouse nor keyboard give any response.


Edit: Ok, some more experimenting made it work, not perfect, but a tad better :)
I still cant move the mouse when the game is in the background.

With the way you described above you do the following steps to for example answer an IM-message:
Ctrl+Alt+Enter --> wait a few sec --> press Ctrl+Alt+numpad_divide-key --> Alt+TAB to appropriate window.

Edit2: With some more google'ing I found this:
....hit crtl+alt+F2
type startx -- :1
now swap between running x-windows by hitting alt+F7 and alt+F8

It does not seem to be too performance-sucking actually. :)

BUT! This seems to me, be a bit unnecessary to start a whole new gnome-session for this, would be better to have maybe blackbox or fluxbox to be started in this new session.

So, how do you do that then? :D

Edit3: Heres the solution to starting different WM:s!
Start gdmsetup
gdmsetup

Go to "security"
Click on "Add/Modify"
Add another standard on VT 1
Close

Restart GDM
#/usr/sbin/gdm-restart

Choose your sessions in GDM and start them.

Now switch between them by pressing
Ctrl+Alt+F7 / Ctrl+Alt+F8

Done!

Damn that was a serious Edit-marathon :D

Bakal Travel Photos - Turhal Photos on Instagram - Rivas