PDA

View Full Version : smbmount failure


orliville
7th April 2004, 06:35 AM
Hey all,

I'm attmepting to get my linux box to see my music share which resides on my Windows 2003 SBS box. I've try the following command to mount the share:

# smbmount //DOMAIN/music /mnt/music
cli_negprot: SMB signing is mandatory and we have disabled it.
18809: protocol negotiation failed
SMB connection failed

If I execute the smbclient -L //DOMAIN command, I can see the music share just fine. But when I go to mount it, I get the afore mentioned error. Sorry if this is basic, I just can't seem to find exactly what I am looking for.

Using the smbclient //DOMAIN/music command, I am able to see all the files in this share.

prisen
10th April 2004, 05:17 PM
smbfs doesn't support SMB signing. You need to enable CIFS support in the kernel and mount it that way.

orliville
13th April 2004, 02:16 AM
What would be the best way to go about doing that?

Jman
14th April 2004, 12:10 AM
I'm no expert, but get it from the samba site (http://us1.samba.org/samba/Linux_CIFS_client.html) and follow the instructions in the README (several directories down).

It should be in kernel 2.6, so this won't be a problem for FC2.

rcubed
14th June 2005, 03:33 PM
Had the same problem

Try this command

mount -t cifs -o username=<yourusername>,password=<yourpassword> //DOMAIN/music /mnt/music

You may or may not be able to leave out the username/password stuff. Depends on your environment.

steve_waters
28th June 2005, 02:43 PM
Ah thanks for that!!!!!

-t cifs
saved me as well, what is 'cifs'?

Tall Rif`at Travel Photos - Liben - Tinnanur Photos