PDA

View Full Version : Installing Matlab R14 SP3 on X86_64 FC5


Det0r
24th April 2006, 03:27 AM
Hey guys, I'm still kinda new to linux, so I'm probably doing this completely wrong, but I've been having a few problems with installation of Matlab.

When I follow the instructions from the matlab website (http://www.mathworks.com/access/helpdesk/help/base/install/unix/) :

If you are installing from a CD, execute the following command to run the MathWorks Installer.

/cdrom/install &
In my case /cdrom is /media/MathWorks_R14sp3/ thus I do:
[root@det-lappy matlab]# /media/MathWorks_R14sp3/install &
[1] 3132
bash: /media/MathWorks_R14sp3/install: No such file or directory

Reading around a few sites from a google search I saw that a lot of people put a * at the end of install (what does this do btw?)

[root@det-lappy matlab]# /media/MathWorks_R14sp3/install* &
[2] 3140
[1] Exit 127 /media/MathWorks_R14sp3/install
bash: /media/MathWorks_R14sp3/install_unix.sh: /bin/sh: bad interpreter: Permission denied
I figure this is closer, because now it's trying to run the install_unix.sh, but yeh, now I'm getting a bad interpreter problem :/

Any help is most appreciated thanks.

Det0r
26th April 2006, 12:08 AM
Can anyone help?

dubrict
29th April 2006, 11:00 AM
I have the exact same problem... I've been looking for a solution, but there doesn't seem to be any help out there yet.. :(

Det0r
29th April 2006, 11:27 AM
I'm going in to see my uni departments head IT admin tomorrow; he's a gawd with Linux and he has Matlab setup on all my departments comps, so hopefully he can help. I'll post what he did once it's done.

dubrict
29th April 2006, 11:30 AM
actually I just found something, go to:
http://www.mathworks.com/support/solutions/data/1-O7POO.html?1-O7POO

it shows how to install the 32-bit version... but first you need to copy the files to your hard drive

dubrict
29th April 2006, 12:19 PM
I have the student version, and there's no support in it for 64-bit linux... so I have to come up with several workarounds to get it to install in 32. Most of the problems come from having to activate it though...

Det0r
30th April 2006, 12:36 AM
So the third work around:
3) Copy all 3 CD's into a single directory on your local hard drive and then run the installer with the -glnx86 and -nocp flags. Note some files will be overwritten during this process.
worked for you?

Det0r
30th April 2006, 01:27 AM
[root@det-lappy matlab]# /home/joe/matlabcd/MathWorks_R14sp3/install_unix.sh
-------------------------------------------------------------------

An error status was returned by the program 'xsetup',
the X Window System version of 'install'. The following
messages were written to standard error:

/home/joe/matlabcd/MathWorks_R14sp3/unix/update/install/main.sh: line 162: /home/joe/matlabcd/MathWorks_R14sp3/unix/update/bin/glnxa64/xsetup: No such file or directory

Attempt to fix the problem and try again. If X is not available
or 'xsetup' cannot be made to work then try the terminal
version of 'install' using the command:

install* -t or INSTALL* -t

-------------------------------------------------------------------

Sorry! Setup aborted . . .

[root@det-lappy matlab]# /home/joe/matlabcd/MathWorks_R14sp3/install_unix.sh -glnx86
-------------------------------------------------------------------

An error status was returned by the program 'xsetup',
the X Window System version of 'install'. The following
messages were written to standard error:

/home/joe/matlabcd/MathWorks_R14sp3/unix/update/bin/glnx86/xsetup: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

Attempt to fix the problem and try again. If X is not available
or 'xsetup' cannot be made to work then try the terminal
version of 'install' using the command:

install* -t or INSTALL* -t

-------------------------------------------------------------------

Sorry! Setup aborted . . .

[root@det-lappy matlab]# /home/joe/matlabcd/MathWorks_R14sp3/install_unix.sh -glnx86 -t


Welcome to the MATLAB Installer

---------------------------------------------------------------------------
| Please review the license agreement on the next set of screens. On any |
| screen the options to proceed are at the bottom. Type your response |
| at the prompt. |
---------------------------------------------------------------------------

The MathWorks, Inc. [screen 1 of 73]
-------------------
Software License


IMPORTANT NOTICE

THE LICENSE AGREEMENT TOGETHER WITH ANY APPLICABLE ADDENDUM REPRESENTS
THE ENTIRE AGREEMENT BETWEEN YOU (THE "LICENSEE") AND THE MATHWORKS,
INC. ("MATHWORKS") CONCERNING THE PROGRAM(S) AND DOCUMENTATION
DELIVERED HEREUNDER.

----------------------------------------------------------------------------
>>>>>>>> For this License Agreement <<<<<<<<
Enter either: <return> a r p ^C
To: [next screen] [accept] [reject] [print] [abort]
----------------------------------------------------------------------------
> a
/home/joe/matlabcd/MathWorks_R14sp3/unix/update/bin/glnx86/xsetup: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory


Argh, getting so close >_<
Did you actually get it to install? I'm just about to start googling for libXp.so.6

Det0r
30th April 2006, 02:18 AM
That was easy

yum install libXp


haha, it's installing now, hopefully it works >_<

Det0r
30th April 2006, 03:10 AM
ZOMG ITS GOING!!!!

It installed fine (well, after doing all of the above, barely fine I guess); then I was faced with the next problem:

[root@det-lappy bin]# ./matlab -glnx86
[root@det-lappy bin]# ---------------------------------------------------------------------------
Error: Cannot locate Java Runtime Environment (JRE).
The directory /usr/local/matlab/sys/java/jre/glnxa64/jre does not exist.
---------------------------------------------------------------------------


It's a rather lame fix, but I just made the above directory:

[root@det-lappy bin]# cd ..
[root@det-lappy matlab]# cd sys/java/jre/
[root@det-lappy jre]# mkdir glnxa64
[root@det-lappy jre]# cp -r glnx86/*.* glnxa64/


Then it worked

[root@det-lappy bin]# ./matlab -glnx86
[root@det-lappy bin]# /usr/share/themes/Clearlooks/gtk-2.0/gtkrc:58: Engine "clearlooks" is unsupported, ignoring


Took a while to load, but it opened up, and gave me the registration screen for my matlab (it also gave me my machine ID), so I could then register my Matlab, and then I just opened it:


[root@det-lappy bin]# ./matlab -glnx86



Hope it works for you ^_^!

dubrict
3rd May 2006, 12:02 AM
Yeah, I tried the same thing you did, copying the java files into a new directory. That didn't work for me, so I called up Mathworks and had a chat with them about how they don't seem to think students are technologically advanced enough to have 64-bit computers... they gave me a workaround for the product activation and told me how to run matlab without Java. I don't know how useful the program will be with the limited functionality that will afford, though.
I haven't tried it out yet, as I'm a student at Clarkson and it's final exam time... I'll probably get to it tomorrow, when everything's done. Only problem is, I'm going home to a dial-up connection.. :-\

Det0r
3rd May 2006, 01:07 AM
haha, I own 2 64-bit personal computers, including my laptop, how can they think students dont use 64 bit, it's becoming the main stream home processor O_O

I got it all going, but when I try to execute an M-file Matlab crashes, so yeh, if you could post the Java work around it would be most appreciated :)

dubrict
3rd May 2006, 01:21 AM
Well, The tech support guys emailed me a license file to replace mine with, because they saw that I had already registered it on this computer. The workaround was adding " -nojvm" when running matlab from the terminal.

I just installed it and got it working. I tried the idea of making the new java folder again, and this time it worked... no idea why it didn't last time. I have it all running now, with no m-file problems...at least not yet. I don't need to use -nojvm. If you use that, it just runs the matlab command window from your terminal, which I don't find very favorable.

I'll let you know if I find anything about your m-file problems.

cbeane357
5th October 2006, 05:36 PM
Well, The tech support guys emailed me a license file to replace mine with, because they saw that I had already registered it on this computer. The workaround was adding " -nojvm" when running matlab from the terminal.

I just installed it and got it working. I tried the idea of making the new java folder again, and this time it worked... no idea why it didn't last time. I have it all running now, with no m-file problems...at least not yet. I don't need to use -nojvm. If you use that, it just runs the matlab command window from your terminal, which I don't find very favorable.

I'll let you know if I find anything about your m-file problems.
If you are running FC5 the cdrom is probably automounting. If it is you need to umount the cdrom and do this:

1) create a mounting point (as root: mkdir /media/cdrom)

2) manually mount the Matlab cdrom:
mount -t iso9660 /dev/hda /media/cdrom (where /dev/hda is my device node)

3) cd /media

4) # ./cdrom/install (as root)

Venilale Travel Photos - Khotkovo Photos on Instagram - Cimin Travel Photos